ООО ЭкоЮнит
FAQSearchMemberlistUsergroupsFilesLog inRegisterГлавная
printer-friendly view
 
AuthorMessage
Александр Романов Gender:Male

Постоянный клиент


Joined: 29 Jul 2012
Show/Hide

Приветствую!
Начал разбираться с планами обмена на БСП. В форме загрузки правил конвертации увидел флажок "Использовать фильтр выборочной регистрации объектов". Для чего он вообще используется и чем грозит снятие флажка? В гугле нашёл только одну тему forum.mista.ru.....?id=639709 без ответов и пару топиков на инфостарт.ру.
Поиск по конфигурации внятного ответа тоже не дал. Через чехарду вызовов процедур трудно что-то понять.
Back to topOffline View user's profile
Sergey Gender:Male


Местный босс - администратор


Joined: 06 Jan 2005
Show/Hide

Она нужна как раз для выборочной регистрации объектов. Перед записью какого-либо существующего объекта, включенного в состав плана обмена, проверяются текущие значения реквизитов и реквизиты по ссылке в базе данных, то есть записанного объекта, для исключения лишней регистрации и уменьшения объёма данных при обмене. Состав реквизитов для сравнения извлекается из правил конвертации объекта (ПКО) или таблицы значений, которые сохраняются в параметрах сеанса при начале работы системы.

Это видно из кода в модуле ОбменДаннымиСобытия
Code:
    
Функция ОбъектМодифицированДляПланаОбменаПопыткаИсключение(Источник, ОбъектМетаданных, ИмяПланаОбмена, РежимЗаписи, ЗарегистрироватьОбъектКВыгрузке)
    ..........................................
    ИмяОбъекта = ОбъектМетаданных.ПолноеИмя();
    ТаблицаРеквизитовРегистрации = ОбменДаннымиПовтИсп.ПолучитьТаблицуРеквизитовРегистрации(ИмяОбъекта, ИмяПланаОбмена);
    Если ТаблицаРеквизитовРегистрации.Количество() = 0 Тогда
        // если правила ВРО не заданы, то считаем, что фильтра ВРО нет.
        // объект модифицирован всегда
        Возврат Истина;
    КонецЕсли;
    Для Каждого СтрокаТаблицыРеквизитовРегистрации ИЗ ТаблицаРеквизитовРегистрации Цикл
        ЕстьИзмененияВерсийОбъектов = ОпределитьИзмененияВерсийОбъекта(Источник, СтрокаТаблицыРеквизитовРегистрации);
        Если ЕстьИзмененияВерсийОбъектов Тогда
            Возврат Истина;
        КонецЕсли;
    КонецЦикла;
    
    // если дошли до конца, то объект не изменился по реквизитам регистрации;
    // регистрация на узлах не нужна
    Возврат Ложь;
 


Если необходимо всегда регистрировать объекты при простой записи или перепроведении документов, снимите этот флажок.
А почему он находится именно в форме правил обмена, ну не задумывался. Будем считать, такова барская воля разработчиков.

Внятно объяснил? Smile

_________________
Профессионал - это тот же дилетант, только знающий где ошибется. Генератор db_update.php для phpBB2 с некоторыми удобствами.
Как ставить моды. Что такое [SQL] и с чем его едят | Как правильно задавать вопросы и получать адекватные ответы | Правила форума
Бесплатная техподдержка только на форуме! Не надо стучаться в аську, скайп, слать емайлы, пытаться писать в приват. Спасибо за понимание. Please do not PM, ICQ, Skype or email me for support help - you won't get any reply. If you have a question or issue, post it in the appropriate forum/topic. Thanks!
Back to topOffline View user's profile Visit poster's website Skype Name
Александр Романов Gender:Male

Постоянный клиент


Joined: 29 Jul 2012
Show/Hide

Да, спасибо за разъяснение. Извините что долго не отвечал.
Back to topOffline View user's profile
Display posts from previous:   

Summary Rating For >> Использовать фильтр выборочной регистрации объектов в правилах обмена для БСП
Average Rating: 0.00 :: Min Rating: 0 :: Max Rating: 0 :: Number of Ratings: 0
Choose Rating: 1   2   3   4   5  

Similar Topics
Topic Author Forum Replies Last Post
No new posts Sticky: Выгрузка данных из Управления торговлей 10.3 / 10.2 в Бухгалтерию предприятия, редакция 2.0 ...
Обработка (обмен данными УТ 10.3 / 10.2 - БП 2.0)
Обработка предназначена для выгрузки документов из конфигурации УТ 10.3 / 10.2 в конфигурацию БП 2.0 без использования планов обмена. :arrow: Поддерживаемые релизы (для платформ 1С Предприятия 8.1 и 8.2): Управление
Sergey 1Сv8: Программирование, отчёты, обработки, статьи 72 Wed 18 Mar, 2015 12:21 View latest post
Sergey
No new posts Sticky: Выгрузка данных из Управления торговлей 10.3 / УТ 10.2 в Бухгалтерию предприятия, редакция 3...
Обработка (управляемое и обычное приложение, обмен данными УТ 10.3/10.2 - БП 3.0)
Предназначена для переноса документов и справочников из базы УТ 10.3/УТ 10.2 в базу БП 3.0 без использования планов обмена. :arrow: Поддерживаемые релизы (для платформ 1С Предприятия 8.1, 8.2, 8.3): Управление торговлей:
Sergey 1Сv8: Программирование, отчёты, обработки, статьи 86 Today at 17:09 View latest post
Виталий1984
No new posts Регистрация изменений / удаление регистрации для обмена (управление регистрацией) (v1.2.6) д...
Обработка (управляемое и обычное приложение), обмен данными
Назначение: универсальная обработка для регистрации, отмены регистрации изменений (управления регистрацией) в планах обменов, мониторинга состояния обмена данными как в режиме управляемого, так и обычного приложения без
Sergey 1Сv8: Программирование, отчёты, обработки, статьи 28 Fri 18 Aug, 2017 01:06 View latest post
Sergey
No new posts Удаляются строки в табличной части при переносе данных
обмен данными
Сергей, приветствую! Не поможете с конвертацией данных? целый день мозг ломаю. Пытаюсь сделать перегрузку одного документа в другую базу. В документе есть две табличные части. В приёмнике они загружаются в одну тч.
Александр Романов 1Сv8: Программирование, отчёты, обработки, статьи 2 Tue 28 Jan, 2014 22:54 View latest post
Александр Романов
No new posts Простой способ регистрации изменений реквизитов объектов в 1С Предприятии 8.X
Потребовалось отслеживать изменения реквизитов справочников, документов (в т.ч. и табличных частях), так как штатный журнал регистрации не даёт достаточной информации. Поскольку внедрять в рабочую конфу какие-то
Sergey 1Сv8: Программирование, отчёты, обработки, статьи 0 Tue 05 May, 2009 17:29 View latest post
Sergey






All times are UTC + 3 hours
Users browsing this topic:
Registered Users: None

Jump to:   
printer-friendly view
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
/a
Username:

Password:

Log me on automatically each visit
  Яндекс.Метрика
CrackerTracker © 2004 - 2018 CBACK.de