ООО ЭкоЮнит
FAQSearchMemberlistUsergroupsFilesLog inRegisterГлавная
printer-friendly view
 
AuthorMessage
Sergey Gender:Male


Местный босс - администратор


Joined: 06 Jan 2005
Show/Hide

Code:

//Процедура, сортирующая табличную часть документа по значению реквизита номенклатуры
Процедура СортироватьТабличнуюЧастьПоРеквизитуНоменклатуры(ДокументОбъект, ИмяТабличнойЧасти = "Товары", ИмяРеквизита = "Код", НаправлениеСортировки = "Возр") Экспорт

   МетаданныеДокумента = ДокументОбъект.Метаданные();
   Если НЕ ОбщегоНазначения.ЕстьТабЧастьДокумента(ИмяТабличнойЧасти, МетаданныеДокумента) Тогда // Нет такой таб. части в документе
      Возврат;
   КонецЕсли;
   ТабличнаяЧасть = ДокументОбъект[ИмяТабличнойЧасти];
   Если ТабличнаяЧасть.Количество() <= 1 Тогда
      Возврат;
   КонецЕсли;

   ВременнаяТаблица = Новый Запрос;
   ВременнаяТаблица.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
   ВременнаяТаблица.Текст = "
   |ВЫБРАТЬ
   |    *
   |ПОМЕСТИТЬ ВременнаяТаблица
   |ИЗ &ТаблицаДанных КАК ТаблицаДанных
   |";
   ВременнаяТаблица.УстановитьПараметр("ТаблицаДанных", ТабличнаяЧасть);
   ВременнаяТаблица.Выполнить();

   Запрос = Новый Запрос();
    Запрос.МенеджерВременныхТаблиц = ВременнаяТаблица.МенеджерВременныхТаблиц;
   Запрос.Текст = "
   |ВЫБРАТЬ
   |   *
   |ИЗ
   |   ВременнаяТаблица
   |УПОРЯДОЧИТЬ ПО Номенклатура." + ИмяРеквизита + " " + НаправлениеСортировки;

   ДокументОбъект[ИмяТабличнойЧасти].Загрузить(Запрос.Выполнить().Выгрузить());
   Запрос.МенеджерВременныхТаблиц.Закрыть();

КонецПроцедуры

_________________
Профессионал - это тот же дилетант, только знающий где ошибется. Генератор db_update.php для phpBB2 с некоторыми удобствами.
Как ставить моды. Что такое [SQL] и с чем его едят | Как правильно задавать вопросы и получать адекватные ответы | Правила форума
Бесплатная техподдержка только на форуме! Не надо стучаться в аську, скайп, слать емайлы, пытаться писать в приват. Спасибо за понимание. Please do not PM, ICQ, Skype or email me for support help - you won't get any reply. If you have a question or issue, post it in the appropriate forum/topic. Thanks!
Back to topOffline View user's profile Visit poster's website Skype Name
Display posts from previous:   

Summary Rating For >> Функция. Сортировка табличной части документа по значению реквизита номенклатуры (УТ 10.3)
Average Rating: 0.00 :: Min Rating: 0 :: Max Rating: 0 :: Number of Ratings: 0
Choose Rating: 1   2   3   4   5  

Similar Topics
Topic Author Forum Replies Last Post
No new posts Удаляются строки в табличной части при переносе данных
обмен данными
Сергей, приветствую! Не поможете с конвертацией данных? целый день мозг ломаю. Пытаюсь сделать перегрузку одного документа в другую базу. В документе есть две табличные части. В приёмнике они загружаются в одну тч.
Александр Романов 1Сv8: Программирование, отчёты, обработки, статьи 2 Tue 28 Jan, 2014 22:54 View latest post
Александр Романов
No new posts Функция. Формирование и заполнение структуры вложения электронного письма (УТ 10.3)
Управление торговлей 10.3 (отправка электронных писем)
Эту функцию я применяю в своих обработках для УТ 10.3 при отсылке писем. Сформированная структура предназначается для списка файлов вложений при передаче в функцию УправлениеЭлектроннойПочтой.НаписатьПисьмо() Code //
Sergey 1Сv8: Программирование, отчёты, обработки, статьи 1 Sun 19 Feb, 2012 11:57 View latest post
berator37
No new posts Копирование из буфера обмена и вставка изображений для номенклатуры (Управление торговлей 10.3)
Обработка. Быстрая вставка изображения из буфера обмена и запись в базу.
Обработка предназначена для быстрой вставки изображения из буфера обмена и записи в базу данных для выбранного элемента номенклатуры. Позволяет также заместить основное изображение импортированным из буфера обмена.
Sergey 1Сv8: Программирование, отчёты, обработки, статьи 1 Mon 15 Aug, 2011 10:24 View latest post
MAX3000
No new posts Сроки хранения номенклатуры на складах для Управления Торговлей 10.3
Отчет (обычное приложение)
Отчет «Сроки хранения номенклатуры на складах» позволяет получить информацию о сроках хранения товара в разрезе интервалов с детализацей по складам, номенклатуре, характеристикам и сериям номенклатуры. Сроки
Sergey 1Сv8: Программирование, отчёты, обработки, статьи 2 Thu 30 Aug, 2018 08:11 View latest post
Sergey
No new posts Сроки резервирования номенклатуры на складах для Управления Торговлей 10.3
Отчет (обычное приложение)
Отчет «Сроки резервирования на складах» позволяет получить информацию о сроках нахождения номенклатуры в резерве в разрезе интервалов с детализацей по складам, номенклатуре, характеристикам и сериям
Sergey 1Сv8: Программирование, отчёты, обработки, статьи 0 Fri 02 Apr, 2010 19:41 View latest post
Sergey






All times are UTC + 3 hours
Users browsing this topic:
Registered Users: None

Jump to:   
printer-friendly view
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
/a
Username:

Password:

Log me on automatically each visit
  Яндекс.Метрика
CrackerTracker © 2004 - 2018 CBACK.de