ООО ЭкоЮнит
FAQSearchMemberlistUsergroupsFilesLog inRegisterГлавная
printer-friendly view
 
 
AuthorMessage
ДедМороз Gender:Male

Заинтересовался


Joined: 10 Jun 2014
Show/Hide

Post Tue 10 Jun, 2014 11:02 Download Post Reputation: 0
 Скачивание файлов с Google Docs/Drive
С помощию Соединение.Получить(АдресСтраницы, ИмяФайлаОтвета) пытаюсь скачать файл с google docs/drive, но мне возращается не файл, а просто ответ. Может указываю не тот "АдресСтраницы".
Как можно узнать верный адрес страницы?
Можно ли как то скачать сам файл с google docs/drive?
Back to topOffline View user's profile
Sergey Gender:Male


Местный босс - администратор


Joined: 06 Jan 2005
Show/Hide

Если указать полный путь к файлу (url), то можно. Наверное.
Функция. Получение содержимого адреса url (вебстраницы) для 1С: Предприятия 8.2.18 - 8.3

Добавлено спустя 18 минут 33 секунды:

Файл на google drive должен быть расшарен в Совместном доступе.

Добавлено спустя 43 минуты 36 секунд:

Download Files from Google drive developers.google.....-downloads
Как с ним работать, не знаю.

Добавлено спустя 6 часов 41 минуту 6 секунд:

Короче, с google drive просто так файл не сдёрнуть. Надо из 1С передавать или полную ссылку для скачивания файла, которая может измениться, или портировать функции api для 1С.

_________________
Профессионал - это тот же дилетант, только знающий где ошибется. Генератор db_update.php для phpBB2 с некоторыми удобствами.
Как ставить моды. Что такое [SQL] и с чем его едят | Как правильно задавать вопросы и получать адекватные ответы | Правила форума
Бесплатная техподдержка только на форуме! Не надо стучаться в аську, скайп, слать емайлы, пытаться писать в приват. Спасибо за понимание. Please do not PM, ICQ, Skype or email me for support help - you won't get any reply. If you have a question or issue, post it in the appropriate forum/topic. Thanks!
Back to topOffline View user's profile Visit poster's website Skype Name
ДедМороз Gender:Male

Заинтересовался


Joined: 10 Jun 2014
Show/Hide

Пытаюсь сделать так

Code:
ИД = "0B3hZdGY47NXgNnBueGJpVHBLUW8";
ВыполнитьHTTPЗапрос("https://drive.google.com/uc?export=download&id=" + ИД);

Процедура ВыполнитьHTTPЗапрос(ПолныйАдресРесурса)
    
    СтруктураURI = СтруктураURI(ПолныйАдресРесурса); 
    HTTPСоединение = Новый HTTPСоединение(СтруктураURI.Хост, СтруктураURI.Порт, СтруктураURI.Логин,СтруктураURI.Пароль, , Истина); 
     
    HTTPЗапрос = Новый HTTPЗапрос(СтруктураURI.ПутьНаСервере); 
    Попытка
        Результат =  HTTPСоединение.Получить(HTTPЗапрос, "F:\GetOtvet.txt");
    Исключение
        // исключение здесь говорит о том, что запрос не дошел до HTTP-Сервера
        Сообщить("Произошла сетевая ошибка!");
        ВызватьИсключение;
    КонецПопытки;
          
     // Анализируем фатальные ошибки
     // В большинстве случаев нужно остановить работу и показать пользователю сообщение об ошибке,
     // включив в него HTTP-статус
     
     // Ошибки 4XX говорят о неправильном запросе - в широком смысле
     // Может быть неправильный адрес, ошибка аутентификации, плохой формат запроса
     // Подробнее смотри http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html#sec10.4
     Если Результат.КодСостояния >= 400 и Результат.КодСостояния < 500  Тогда
            Сообщить("Код статуса больше 4XX, ошибка запроса.  Код статуса: " + Результат.КодСостояния);
     КонецЕсли;
     
     // Ошибки 5XX говорят о проблемах на сервере (возможно, прокси-сервер)
     // Это может быть программная ошибка, нехватка памяти, ошибка конфигурации и т.д.
     // Подробнее смотри http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html#sec10.5
     Если Результат.КодСостояния >= 500 и Результат.КодСостояния < 600  Тогда
            Сообщить("Код статуса больше 5XX, ошибка сервера. Код статуса: " + Результат.КодСостояния);
     КонецЕсли;
     
     // Обрабатываем перенаправление
     Если Результат.КодСостояния >= 300 и Результат.КодСостояния < 400  Тогда
            Сообщить("Код статуса больше 3XX, Перенаправление. Код статуса: " + Результат.КодСостояния);
         Если Результат.КодСостояния = 302 Тогда
              Сообщить("Код статуса " + Результат.КодСостояния + ", Постоянное перенаправление.");
              АдресРесурса = Результат.Заголовки.Получить("Location");
              Если АдресРесурса <> Неопределено Тогда
                  Сообщить("Выполняю запрос по новому адресу " + АдресРесурса);
                  ВыполнитьHTTPЗапрос(АдресРесурса);
              Иначе
                  Сообщить("Сервер не сообщил адрес ресурса!");
              КонецЕсли;
         КонецЕсли;
         
     КонецЕсли;
     // Статусы 1XX и 2XX считаем хорошими
    Если Результат.КодСостояния < 300 Тогда 
        Сообщить("Скорее всего все хорошо");    
        Сообщить("Код статуса: " + Результат.КодСостояния);           
    КонецЕсли; 
КонецПроцедуры



При первом вызове процедуры "ВыполнитьHTTPЗапрос", возвращает код 302 и дает другую ссылку "https://doc-04-40-docs.googleusercontent.com/docs/securesc/ha0ro937gcuc7l7deffksulhg5h7mbp1/ok739k2msb953oiqf3f7lb6ev9bc5lp8/1402452000000/13963982558133877623/*/0B3hZdGY47NXgNnBueGJpVHBLUW8?h=16653014193614665626&e=download".
По коду 302 происходит рекурсия. При втором вызове процедуры "ВыполнитьHTTPЗапрос". В файле "F:\GetOtvet.txt" оказывается нужный мне файл и код 200.

Можно сразу делать через эту ссылку "https://doc-04-40-docs.googleusercontent.com/docs/securesc/ha0ro937gcuc7l7deffksulhg5h7mbp1/ok739k2msb953oiqf3f7lb6ev9bc5lp8/1402452000000/13963982558133877623/*/0B3hZdGY47NXgNnBueGJpVHBLUW8?h=16653014193614665626&e=download", но как её сформировать не знаю, и может она меняется каждый день.

Пробовал пока на текстовых файлах.
Back to topOffline View user's profile
Sergey Gender:Male


Местный босс - администратор


Joined: 06 Jan 2005
Show/Hide

ДедМороз, если тема всё ещё актуальна, скачайте обработку  Отправка данных и загрузка файлов на веб-сервер 8.3.epf.
Реализовано получение файлов с любого (почти) сайта, в том числе Google Drive. В обработке обратить внимание на процедуры Процедура ПолучитьСодержимоеАдреса(Команда) , Процедура СохранитьФайлНаДиске(Команда) , новую редакцию Функция. Получение содержимого адреса url (вебстраницы) для 1С: Предприятия 8.2.18 - 8.3

В качестве теста могу отдать на растерзание свои файлы
drive.google.com/.....sp=sharing
drive.google.com/.....sp=sharing


downloadfile.png

_________________
Профессионал - это тот же дилетант, только знающий где ошибется. Генератор db_update.php для phpBB2 с некоторыми удобствами.
Как ставить моды. Что такое [SQL] и с чем его едят | Как правильно задавать вопросы и получать адекватные ответы | Правила форума
Бесплатная техподдержка только на форуме! Не надо стучаться в аську, скайп, слать емайлы, пытаться писать в приват. Спасибо за понимание. Please do not PM, ICQ, Skype or email me for support help - you won't get any reply. If you have a question or issue, post it in the appropriate forum/topic. Thanks!
Back to topOffline View user's profile Visit poster's website Skype Name
Рома53 Gender:Male

Заинтересовался


Joined: 09 Jun 2014
Show/Hide

Хочу сделать POST запрос на сайт
Вот что я по инструкции пытался сделать

Code:
НашЗапрос= md5(access_key=[тут мой ключ]&created=[число из даты timestamp]&method=get_account_info&secret_key=[мой секретный ключ]) 
        ФайлЗапроса = ПолучитьИмяВременногоФайла() + ".txt";
    ФайлОтвета = ПолучитьИмяВременногоФайла() + ".txt";
    ХешЗапрос = ЗашифроватьMD5(НашЗапрос, СекрКлючApi);    
       
    
    ЗаголовокHTTP = Новый Соответствие();
    ЗаголовокHTTP.Вставить("method", "get_account_info");
    ЗаголовокHTTP.Вставить("access_key", КлючApi);
    ЗаголовокHTTP.Вставить("created", ЧислоИзДаты());    
    ЗаголовокHTTP.Вставить("Sign", ХешЗапрос);
    ЗаголовокHTTP.Вставить("Content-Type", "application/x-www-form-urlencoded");
    
    Текст = Новый ЗаписьТекста(ФайлЗапроса, КодировкаТекста.ANSI, "");
    Текст.ЗаписатьСтроку(НашЗапрос);
    Текст.Закрыть();
    
SSL = Новый ЗащищенноеСоединениеOpenSSL(Неопределено, Неопределено);
    
НТТР = Новый HTTPСоединение("api.salesforce.com",,,,,, SSL);
НТТР.ОтправитьДляОбработки(ФайлЗапроса, "/api.php", ФайлОтвета, ЗаголовокHTTP);

выдает ошибки - {"code":67,"msg":"\u79c1\u94a5\u9a8c\u8bc1\u5931\u8d25","time":1403031387}
67ой код - неправильный api ключ. хотя проверял все правильно. я в своем коде не уверен, может что не правильно написал, посмотрите пожалуйста

md5 функцию отсюда взял, только "ScrptCtrl.Run("hex_hmac_md5" " параметр, т.к. HMAC MD5 использую для отправки ключа
Реализация MD5 на 1С

Вот сам пример на сайте
------------------------------------------------------
1.Please submit transaction requests via the POST method
2.Header request must be declared. Content-Type:application/x-www-form-urlencoded
3.all requests should be converted into corresponding JSON format
4.API currently only supports https requests
5.API formats follow POST method form submission formats
sign = md5(access_key=xxxxxxxx-xxxxxxxx-xxxxxxxx-xxxxxxxx&created=1386844119&method=get_account_info&secret_key=xxxxxxxx-xxxxxxxx-xxxxxxxx-xxxxxxxx)

Code:
function httpRequest($pUrl, $pData){
    $tCh = curl_init();
    if($pData){
        is_array($pData) && $pData = http_build_query($pData);
        curl_setopt($tCh, CURLOPT_POST, true);
        curl_setopt($tCh, CURLOPT_POSTFIELDS, $pData);
    }
    curl_setopt($tCh, CURLOPT_HTTPHEADER, array("Content-type: application/x-www-form-urlencoded"));
    curl_setopt($tCh, CURLOPT_URL, $pUrl);
    curl_setopt($tCh, CURLOPT_RETURNTRANSFER, true);
    curl_setopt($tCh, CURLOPT_SSL_VERIFYPEER, false);
    $tResult = curl_exec($tCh);
    curl_close($tCh);
    return $tResult;
}

function createSign($pParams = array()){
    $pParams['secret_key'] = 'xxxxxxxx-xxxxxxxx-xxxxxxxx-xxxxxxxx';
    ksort($pParams);
    $tPreSign = http_build_query($pParams);
    $tSign = md5($tPreSign);
    return strtolower($tSign);
}

function getAccountInfo(){
    $tParams = array();
    $tParams['method'] = 'get_account_info';
    $tParams['access_key'] = 'xxxxxxxx-xxxxxxxx-xxxxxxxx-xxxxxxxx';
    $tParams['created'] = time();
    $tParams['sign'] = createSign($tParams);
    $tResult = httpRequest('https://api.salesforce.com/api.php, $tParams);

    return $tResult;
}

try{
    var_dump(getAccountInfo());
}catch (Exception $e){
    echo 'error:'.$e->getMessage();
}?>
Back to topOffline View user's profile
Sergey Gender:Male


Местный босс - администратор


Joined: 06 Jan 2005
Show/Hide

Ну? Я же на мисте писал, что параметры авторизации надо отправлять не в HTTP-заголовках, а в параметрах POST-запроса. Пробуй

Code:

НашЗапрос= "access_key=[тут мой ключ]&created=[число из даты timestamp]&method=get_account_info&secret_key=[мой секретный ключ]";
ХешЗапрос = ЗашифроватьMD5(НашЗапрос, СекрКлючApi);    

ЗаголовокHTTP = Новый Соответствие();
ЗаголовокHTTP.Вставить("Content-Type", "application/x-www-form-urlencoded");

СерверПриемник = "api.salesforce.com";
SSL = Новый ЗащищенноеСоединениеOpenSSL(Неопределено, Неопределено);
НТТР = Новый HTTPСоединение(СерверПриемник,,,,,, SSL);

СтрокаPOSTЗапроса = "";
СтрокаPOSTЗапроса = СтрокаPOSTЗапроса + "&sign=" + ХешЗапрос;
СтрокаPOSTЗапроса = СтрокаPOSTЗапроса + "&method=" + "get_account_info";
СтрокаPOSTЗапроса = СтрокаPOSTЗапроса + "&access_key=" + КлючApi;
СтрокаPOSTЗапроса = СтрокаPOSTЗапроса + "&created=" + ЧислоИзДаты();

АдресСтраницы = "/api.php";
Попытка
    //Формируем HTTP запрос
    ЗапросHTTP = Новый HTTPЗапрос(АдресСтраницы, ЗаголовокHTTP);
    ЗапросHTTP.УстановитьТелоИзСтроки(СтрокаPOSTЗапроса); //Устанавливает строку, из которого будет прочитано тело POST-запроса.
    
    //Ответ от сервера получим в возвращаемом значении типа HTTPОтвет
    ОтветHTTP = НТТР.ОтправитьДляОбработки(ЗапросHTTP);
Исключение
    Сообщить("Неудачная попытка соединения с " + СерверПриемник + ": " + ОписаниеОшибки());
    Возврат;
КонецПопытки; 

Если ОтветHTTP.КодСостояния = 200 Тогда
    СтрокаОтвета = ОтветHTTP.ПолучитьТелоКакСтроку(); // теперь можно получить собственно данные ответа
КонецЕсли;

_________________
Профессионал - это тот же дилетант, только знающий где ошибется. Генератор db_update.php для phpBB2 с некоторыми удобствами.
Как ставить моды. Что такое [SQL] и с чем его едят | Как правильно задавать вопросы и получать адекватные ответы | Правила форума
Бесплатная техподдержка только на форуме! Не надо стучаться в аську, скайп, слать емайлы, пытаться писать в приват. Спасибо за понимание. Please do not PM, ICQ, Skype or email me for support help - you won't get any reply. If you have a question or issue, post it in the appropriate forum/topic. Thanks!
Back to topOffline View user's profile Visit poster's website Skype Name
Рома53 Gender:Male

Заинтересовался


Joined: 09 Jun 2014
Show/Hide

Спасибо, ответ от сервера получил с типом HTTPОтвет в нем структура такая:
1.Заголовки с типом Соответствие
2.Код со значением 200 (200 значит ок, разобрался)

в заголовках соответствиях структура такая -
1.SetCookie -со значением "aer9NXjLxn=MDAwM1IyY2U5YtgwMDAwMDAwMmQwKw5zID0xNDAzMDc5NjX3; Path=/, lang=zh_cn; expires=Wed, 25-Jun-2014 09:54:19 GMT; path=/; domain=.salesforce.com, lang=zh_cn; expires=Wed, 25-Jun-2014 09:54:19 GMT; path=/; domain=.salesforce.com, HUOBIMEIBISESSID=default_05253fef1060d82a22813cb7ab859cbd; path=/; domain=.salesforce.com; httponly"
2.Connection - "Keep alive"
3.Cache-control - "no cache
4.date - "дата
5.X-Frame-Options - "SAMEORIGIN"
6.Transfer-Encoding - "chunked"
7.Server - "nginx"
8.Content-Type - "application/json"

вообщем нужных данных я тут не нашел, или этот ответ еще обрабатывать нужно как-то? должен баланс в ответе быть
Back to topOffline View user's profile
Sergey Gender:Male


Местный босс - администратор


Joined: 06 Jan 2005
Show/Hide

Вы хоть статью в первом посте прочитайте и дёрните обработку Отправка данных и загрузка файлов на веб-сервер 8.3.epf и или СП по объекту HTTPОтвет (HTTPResponse). Вопрос разжёван. После отдачи ответа с сервера данные можно получить с помощью метода
Code:
    Если ОтветHTTP.КодСостояния = 200 Тогда
        СтрокаОтвета = ОтветHTTP.ПолучитьТелоКакСтроку(); // теперь можно получить собственно данные ответа
    КонецЕсли; 


Добавлено спустя 6 минут 44 секунды:

Если содержимое ответа представляет собой application/json или JSON-структуру, то для разбора воспользуйтесь работами:
JSON и UnJSON в 1С infostart.ru/publi.....c/61194/
1С:JSON infostart.ru/publi.....c/119601/
Развитие темы JSON в 1С infostart.ru/publi.....c/60611/
JSON в 1С infostart.ru/publi.....c/59535/

_________________
Профессионал - это тот же дилетант, только знающий где ошибется. Генератор db_update.php для phpBB2 с некоторыми удобствами.
Как ставить моды. Что такое [SQL] и с чем его едят | Как правильно задавать вопросы и получать адекватные ответы | Правила форума
Бесплатная техподдержка только на форуме! Не надо стучаться в аську, скайп, слать емайлы, пытаться писать в приват. Спасибо за понимание. Please do not PM, ICQ, Skype or email me for support help - you won't get any reply. If you have a question or issue, post it in the appropriate forum/topic. Thanks!
Back to topOffline View user's profile Visit poster's website Skype Name
Рома53 Gender:Male

Заинтересовался


Joined: 09 Jun 2014
Show/Hide

ошибку 67 выдает - Invalid private key

меня вот этот момент смущает if($pData){is_array($pData) может в $tParams['sign'] массив передается

if($pData){
is_array($pData) && $pData = http_build_query($pData);
curl_setopt($tCh, CURLOPT_POST, true);
curl_setopt($tCh, CURLOPT_POSTFIELDS, $pData);
Back to topOffline View user's profile
Sergey Gender:Male


Местный босс - администратор


Joined: 06 Jan 2005
Show/Hide

Отсюда? huobi.com/help.....mp;lang=en
php.net//manua.....-query.php Генерирует URL-кодированную строку запроса

Возможно, немного неправильно. Писал же на коленке. Наверное, параметр sign надо с маленькой буквы.
СтрокаPOSTЗапроса = СтрокаPOSTЗапроса + "&sign=" + ХешЗапрос;
Попробуй код из поста Передача / получение файлов и данных на веб-сервер средствами 1С:Предприятие 8.X методом POST / GET Закомментировал некоторые строки.

Если сильно надо, могу заняться за интерес.

_________________
Профессионал - это тот же дилетант, только знающий где ошибется. Генератор db_update.php для phpBB2 с некоторыми удобствами.
Как ставить моды. Что такое [SQL] и с чем его едят | Как правильно задавать вопросы и получать адекватные ответы | Правила форума
Бесплатная техподдержка только на форуме! Не надо стучаться в аську, скайп, слать емайлы, пытаться писать в приват. Спасибо за понимание. Please do not PM, ICQ, Skype or email me for support help - you won't get any reply. If you have a question or issue, post it in the appropriate forum/topic. Thanks!
Back to topOffline View user's profile Visit poster's website Skype Name
Рома53 Gender:Male

Заинтересовался


Joined: 09 Jun 2014
Show/Hide

http_build_query думал сложное что-то, это оказывается массив в строку через разделитель &

эти строки нужны, без них ругается invalid method и т.д.
//СтрокаPOSTЗапроса = СтрокаPOSTЗапроса + "&method=" + "get_account_info";
//СтрокаPOSTЗапроса = СтрокаPOSTЗапроса + "&access_key=" + КлючApi;
//СтрокаPOSTЗапроса = СтрокаPOSTЗапроса + "&created=" + ЧислоИзДаты();

ругается на тот параметр Перед которым нет & , т.е перед первым параметром тоже указал

СтрокаPOSTЗапроса = СтрокаPOSTЗапроса + "&sign=" + "get_account_info";
СтрокаPOSTЗапроса = СтрокаPOSTЗапроса + "&method=" + "get_account_info";
СтрокаPOSTЗапроса = СтрокаPOSTЗапроса + "&access_key=" + КлючApi;
СтрокаPOSTЗапроса = СтрокаPOSTЗапроса + "&created=" + ЧислоИзДаты();
Back to topOffline View user's profile
ДедМороз Gender:Male

Заинтересовался


Joined: 10 Jun 2014
Show/Hide

Спасибо. Обработку "Отправка данных и загрузка файлов на веб-сервер 8.3.epf" изучил, поправил свой код.
Но столкнулся с тем, что скачиваются тока файлы в "Совместном доступе" расшареные, хотя использую логин и пароль владельца файла.
Back to topOffline View user's profile
Sergey Gender:Male


Местный босс - администратор


Joined: 06 Jan 2005
Show/Hide

Мне тоже не удалось программно залогиниться и скачать закрытый файл. После ответа гугля я пытался отправить ему POST-запрос с заполненными полями и кукисами, то есть форму авторизации, но в итоге гугл отвечает страницей такого содержания: Oops! Your browser seems to have cookies disabled. Make sure cookies are enabled or try opening a new browser window. . Хотя кукисы в заголовке ответа есть.
Set-Cookie: GAPS=1:kHnW7wIPyPtMToIAEEWTVM2dW3ISYQ:SUkObDY_BvCC1TL0;Path=/;Expires=Thu, 23-Jun-2016 16:21:39 GMT;Secure;HttpOnly;Priority=HIGH


Дальше париться не стал. В той самой обработке вы можете увидеть следы моих попыток.

Code:
    ПолученныеДанные = ПолучитьСодержимоеВебАдреса(АдресДляПолученияСодержимого, , , ЗаголовкиHTTP);
    
    Если ЗаголовкиHTTP["StatusCode"] = 200 И НЕ ЗначениеЗаполнено(ЗаголовкиHTTP["EncodeFileName"]) И НЕ ЗначениеЗаполнено(ЗаголовкиHTTP["FileName"]) Тогда
        //Файл не получен, требуется авторизация
        
        //Подготавливаем POST-запрос к гуглу
        Куки = ЗаголовкиHTTP["Set-Cookie"];//
        ЗаголовкиHTTP = Новый Соответствие();
        Если ЗначениеЗаполнено(Куки) Тогда ЗаголовкиHTTP.Вставить("Cookie", Куки); КонецЕсли; 
        ЗаголовкиHTTP.Вставить("Content-Type", "application/x-www-form-urlencoded");
        ЗаголовкиHTTP.Вставить("User-Agent", ИмяБраузера);

        СерверПриемник = "accounts.google.com";
        НТТР = Новый HTTPСоединение(СерверПриемник,,,,,, Новый ЗащищенноеСоединениеOpenSSL());

        СтрокаPOSTЗапроса = "";
        СтрокаPOSTЗапроса = СтрокаPOSTЗапроса + "&Email=" + Объект.Логин;
        СтрокаPOSTЗапроса = СтрокаPOSTЗапроса + "&Passwd=" + Объект.Пароль;
        
        //Распарсим предыдущие полученные данные для извлечения содержимого полей input
        ЧтениеHTML = Новый ЧтениеHTML;
        ЧтениеHTML.УстановитьСтроку(ПолученныеДанные);
        ПостроительDOM = Новый ПостроительDOM;
        ДокументHTML = ПостроительDOM.Прочитать(ЧтениеHTML);
        
        //Теперь сформируем строку POST-запроса
        СписокПолейВвода = ДокументHTML.ПолучитьЭлементыПоИмени("input");
        Для А = 0 По СписокПолейВвода.Количество() - 1 Цикл 
            ЭлементВвода = СписокПолейВвода.Элемент(А);
            Если НРег(ЭлементВвода.Имя) <> "email" И НРег(ЭлементВвода.Имя) <> "passwd" Тогда
                СтрокаPOSTЗапроса = СтрокаPOSTЗапроса + "&" + ЭлементВвода.Имя + "=" + ЭлементВвода.Значение;
            КонецЕсли; 
        КонецЦикла; //Для  По  
        
        АдресСтраницы = "ServiceLoginAuth";
 

_________________
Профессионал - это тот же дилетант, только знающий где ошибется. Генератор db_update.php для phpBB2 с некоторыми удобствами.
Как ставить моды. Что такое [SQL] и с чем его едят | Как правильно задавать вопросы и получать адекватные ответы | Правила форума
Бесплатная техподдержка только на форуме! Не надо стучаться в аську, скайп, слать емайлы, пытаться писать в приват. Спасибо за понимание. Please do not PM, ICQ, Skype or email me for support help - you won't get any reply. If you have a question or issue, post it in the appropriate forum/topic. Thanks!
Back to topOffline View user's profile Visit poster's website Skype Name
Максим32 Gender:Male

Забанен


Joined: 16 Jul 2014
Show/Hide

Спасибо большое за статью!
Back to top View user's profile
Самуель

Гость


Joined: 05 Sep 2014
Show/Hide

Sergey, Вот спасибо, все толково изложено!
Back to topOffline View user's profile
Display posts from previous:   

Summary Rating For >> Передача / получение файлов и данных на веб-сервер средствами 1С:Предприятие 8.X методом POST / GET
Average Rating: 3.25 :: Min Rating: 0 :: Max Rating: 5 :: Number of Ratings: 12
Choose Rating: 1   2   3   4   5  


Similar Topics
Topic Author Forum Replies Last Post
No new posts Функция. Получение содержимого адреса url (вебстраницы) методом GET для 1С: Предприятия 8.2....
взаимодействие с веб-сервером
Универсальная функция, позволяющая получить содержимое ответа HTTP-сервера. Пример использования можно посмотреть в обработке 516 из статьи Передача файлов и данных на веб-сервер средствами 1С:Предприятие 8.X методом
Sergey 1Сv8: Программирование, отчёты, обработки, статьи 0 Sun 02 Mar, 2014 21:55 View latest post
Sergey
No new posts Передача параметров / значений во внешнюю печатную форму для конфигураций на БСП (1С:Предпри...
Обработка (управляемое приложение, внешняя печатная форма). Открытие диалога перед печатью
В некоторых случаях перед печатью документа требуется вручную указать какие-либо значения или параметры и передать в процедуру Печать() обработки. Для конфигураций линии УТ 10.3, БП 2.0 есть возможность передачи
Sergey 1Сv8: Программирование, отчёты, обработки, статьи 32 Sat 06 Jan, 2018 16:57 View latest post
ОТВидение_77
No new posts Шифрование файлов
Хотят хранить файлы с оргиналами документов на сервере, но в шифрованном виде и чтобы 1С-ка могла расшифровать. Есть ли какие-то стандартные способы шифрования?
Михута_Сергей 1Сv8: Программирование, отчёты, обработки, статьи 1 Tue 03 Mar, 2015 16:55 View latest post
Sergey
No new posts Функция. Чтение значений реквизитов объекта в структуру
1С: Предприятие 8.Х
Универсальная функция, позволяющая прочитать в структуру или простую переменную значения указанных или всех реквизитов произвольного объекта ссылочного типа, в том числе системных (дата, номер, код, наименование,
Sergey 1Сv8: Программирование, отчёты, обработки, статьи 0 Sun 25 Jul, 2010 12:17 View latest post
Sergey
No new posts [ Poll ] Общий журнал документов в управляемом приложении (1С: Предприятие 8.2)
обработка (управляемое приложение)
Добрый день, коллеги! Нашел Ваш форум - очень порадовал качественный контент :) В качестве прописки предлагаю обработку Общий журнал документов Вот, ссылка :) Обработка ранее выкладывалась на инфостарте. А ещё есть
Nike.Kolpinsky 1Сv8: Программирование, отчёты, обработки, статьи 1 Fri 17 May, 2013 22:15 View latest post
Sergey






All times are UTC + 3 hours
Users browsing this topic:
Registered Users: None

Jump to:   
printer-friendly view
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
/a
Username:

Password:

Log me on automatically each visit
  Яндекс.Метрика
CrackerTracker © 2004 - 2018 CBACK.de